联系方式

电话:150-02886853

 

 点击这里给我发消息      点击这里给我发消息

 

QQ: 358207017

 

网址: www.dcwlkj.cn

 

Email: dcwlkj@dcwlkj.cn

 

首 页>技术信息>解决方案解决方案

Routeros eoip 配置
作者: QQ:86698456  点击次数:   添加时间: 2017-03-12

 

Ethernet over IP  隧道将在Ethernet之间建立一个连接
Ethernet over IP (EoIP) 隧道将在Ethernet之间建立一个连接。
可以工作的环境:lans over internet;LANs over encrypted tunnels ;LANs over 802.11b ‚ad-hoc‚ wireless networks
 
 
1。首先创建ppptp tunnel,首先假设有两台os电脑,一台是www.dcwlkj.cn-A ,(另一台为www.dcwlkj.cn-B)
 
CODE
[admin@www.dcwlkj.cn-A] interface pptp-server> /ppp secret add name=joe service=pptp password=top_s3 local-address=10.0.0.1 www.dcwlkj.cn-B-address=10.0.0.2
 
[admin@www.dcwlkj.cn-A] interface pptp-server> add name=from_www.dcwlkj.cn-B user=joe
 
[admin@www.dcwlkj.cn-A] interface pptp-server> server set enable=yes
 
 
 
而www.dcwlkj.cn-B router 就是一个pptp client:
CODE
[admin@www.dcwlkj.cn-B] interface pptp-client> add name=pptp user=joe connect-to=192.168.1.1 password=top_s3 mtu=1500 mru=1500
 
 
[admin@www.dcwlkj.cn-B] interface pptp-client> enable pptp
 
 
2。接着配置EOIP增加到两个os路由的连接中去,通过刚刚用ppptp拨号建立的ppptp 隧道
在www.dcwlkj.cn-A设置:
CODE
[admin@www.dcwlkj.cn-A] interface eoip> add name="eoip-www.dcwlkj.cn-B" tunnel-id=0 www.dcwlkj.cn-B-address=10.0.0.2
[admin@www.dcwlkj.cn-A] interface eoip> enable eoip-www.dcwlkj.cn-B
 
 
 
在www.dcwlkj.cn-B设置:
CODE
[admin@www.dcwlkj.cn-B] interface eoip> add name="eoip" tunnel-id=0 www.dcwlkj.cn-B-address=10.0.0.1
 
[admin@www.dcwlkj.cn-B] interface eoip> enable eoip-main
 
 
3。桥接EOIP
在www.dcwlkj.cn-A上设置:
CODE
[admin@www.dcwlkj.cn-A] interface bridge> add forward-protocols=ip,arp,other disabled=no
 
[admin@www.dcwlkj.cn-A] interface bridge> port print
Flags: X - disabled
 #   INTERFACE                            BRIDGE
 0   eoip-www.dcwlkj.cn-B                          none
 1   office-eth                           none
 2   isp                                  none
 
 
[admin@www.dcwlkj.cn-A] interface bridge> port set "0,1" bridge=bridge1
(这里的0,1是对应上面的print)
 
同样要在www.dcwlkj.cn-B设置:
CODE
[admin@www.dcwlkj.cn-B] interface bridge> add forward-protocols=ip,arp,other  disabled=no
 
 
[admin@www.dcwlkj.cn-B] interface bridge> port print
Flags: X - disabled
 #   INTERFACE                            BRIDGE
 0   ether                                none
 1   adsl                                 none
 2   eoip-main                            none
 
[admin@www.dcwlkj.cn-B] interface bridge> port set "0,2" bridge=bridge1
(说明同上)
 
 
注意:EOIP的MAC 地址是自己设置的,取间位于00-00-5E-80-00-00 to 00-00-5E-FF-FF-FF
 
两个os的eoip的MAC地址不能一样。。
 
这些都是用熟悉ROUTER OS了以后的才做,既然有人有兴趣,就贴一下吧,上面大都是官方的设置方法,都没有错误。