联系方式

电话:150-02886853

 

 点击这里给我发消息      点击这里给我发消息

 

QQ: 358207017

 

网址: www.dcwlkj.cn

 

Email: dcwlkj@dcwlkj.cn

 

首 页>技术信息>解决方案解决方案

ROS域名管理之花生壳和3322脚本
作者: QQ:86698456  点击次数:   添加时间: 2017-07-28

 

 

花生壳:
:local user "账号"
:local pass "密码"
:local host "域名"
:local pppoe "pppoe-out1"
 
:global oray
/interface pppoe-client monitor $pppoe once
    do={
           :if ($oray!=$"local-address")
               do={
                      :log warning "$host : $[:resolve $host] => $"local-address""
 
                      /tool fetch mode=http user=$user password=$pass dst-path=ddns
                          url="http://ddns.oray.com/ph/update?hostname=$host&myip=$"local-address""
                      :delay 5s ; /file remove ddns ; :set oray $"local-address"
                     }
          }
 
3322:
:local user "账号"
:local pass "密码"
:local host "域名"
:local pppoe "pppoe-out1"
 
:global f3322
/interface pppoe-client monitor $pppoe once
    do={
           :if ($f3322!=$"local-address")
               do={
                      :log warning "$host : $[:resolve $host] => $"local-address""
 
                      /tool fetch mode=http user=$user password=$pass dst-path=ddns
                          url="http://members.3322.org/dyndns/update?system=dyndns&hostname=$host&myip=$"local-address""
                      :delay 5s ; /file remove ddns ; :set f3322 $"local-address"
                     }
          }